We’ve just updated our Unified 2 firmware to version 2.35. Unless this release addresses a bug on your machine and/or board or there is a feature you want that was added (if any) you do not need to update. If you are using our EZBoard with the EZFirmware site this firmware update will be on the EZFirmware site as well for immediate use.

Download from our Unified 2 website at UF2.TH3DStudio.com

Release Notes:

New Board Support

  • EZBoard V2 Added
    • DIY Config will be released after launch

Tweaks/Changes

  • Changed Z fade height default from 10mm to 2mm
  • Lowered Default E Driver Current for TMC Powered Boards

Binaries

  • EZBoard V1.X Binaries Updated
  • EZBoard V2.X Binaries Updated

NOTE: Aside from the new board support, there is nothing noteworthy of this release.

2 thoughts on “Unified 2.35 is now live! | Firmware Update

  1. Dinu Sarbu says:

    Hi, any plan to support the SKR E3 Turbo board with Unified 2 anytime soon? Right now the only BTT supported board is SKR E3 Mini…
    For me (and tons of other users upgrading Ender 3/5 or CR10 to the E3 Turbo) this would be real cool, especially for the ones using already an EZABL pro – like myself 😉

    • Tim Hoogland says:

      You should use whatever firmware they provide (or marlin) and then refer to our vanilla marlin guide here: EZABL Firmware Setup for “Vanilla” Marlin

      We do not have plans to support that board. You should contact BTT to support their own product. We provide easy-to-use firmware for our drop-in board (EZBoard) and we feel BTT should as well for theirs. It is unlikely that we will put out any more firmware for non-OEM boards and boards we don’t carry going forward. We’ve had many SKR E3 Mini users who are not even customers of ours demand support for free and then be very rude to our service team when we inform them that our support is limited to our customers.

      It’s still really odd to us that people purchase these boards from these other companies but then ask a competitor (us) to support someone else’s product because the company selling it has such poor support. I don’t see Samsung users asking Apple to provide IOS firmware support for Samsung phones.

Leave a Reply