Knowledgebase

Search Knowledge Base by Keyword

EZABL – Z Axis Troubleshooting

You are here:
< Back

Details 

After sending out multiple kits and getting feedback from customers that has issues there are many that had Z axises that were not working correctly and this throws off the probe. Before you move forward check that you can easily move your Z axis leadscrews. If there is a lot of resistance then you need to adjust and/or lube your Z axis (both sides if you have dual Z). 

If you are getting inconsistent or odd behavior with the ABL then the likely culprit is a Z axis that is binding up in certain spots. The Z leadscrews should be able to be turned by hand with minimal effort. 

Checks 

With the motors DISABLED try moving the Z by grabbing the coupler (the silver piece that connects the leadscrew to the motor) and turning it. Your couplers should look like below and NOT be stretched out. We sell upgraded couplers if yours are stretched out. 

There should be little to no resistance when you do this. If you have resistance then proceed with the checks below. You must check this by HAND. Just because it moves with the motors does NOT mean you do not have an issue. 

Leadscrew Alignment 

Your leadscrew should be the same distance from the extrusion from TOP to BOTTOM. Measure this. If yours is tilted try the “Z Motor is too close to the extrusion” solution below. 

Resolution/Possible Causes 

  • Z Motor is too close to the extrusion 
  •  Z Leadscrew Brass Nut is Binding 
    • Loosen the screws on the brass nut about 3/4 turn so it is slightly loose in the bracket. This applies to BOTH if you have Dual Z

  • Z Tension Bearings are too tight 
    • On each of your Z axis/X Gantry brackets there is a single wheel. This wheel has an eccentric nut that is use to adjust tension. Use the included wrench and turn this nut until you are just able to move that wheel smoothly with your hand. It should NOT spin freely but it should just touch the extrusion enough to keep the gantry straight. 


  • Z Leadscrew needs Lubrication 
    • If the above fixes do not work try adding lubrication to the leadscrew from top to bottom. You just need a small amount and then move the z up and down completely a few times to spread the lube evenly. I recommend you do this anyways as it will help ensure smooth operation of the printer. 

 

 Z Axis Stepper Amperage is too Low 

If your Z steppers are getting too little power you can verify by moving the Z up 100mm from your control box and then grabbing the Z leadscrews. The motors will be engaged and if you have proper amperage then they will be VERY hard to turn. If you can turn them easily and make the motor skip (you will feel it skipping a step) then you need to check the connections to the Z motor(s). 

If your connections are good then you need to adjust the VREF on your Z axis by turning the small potentiometer about 1/4 turn CLOCKWISE to increase the amperage going to the Z motor. If you have a multi-meter (HIGHLY recommended) you can check the VREF voltage by placing the positive probe on TOP of the potentiometer and the negative to any negative coming from the power supply. The ideal VREF for dual Z is about 0.9-1.0V, single is 0.7-0.8V. 

All Amazon links ARE affiliate links meaning if you purchase the product from the links we receive a referral fee for you purchasing them. This does NOT cost you anything and helps support us.